#24 - xl missing support for encrypted VNC

Owner: Ian Campbell <Ian.Campbell@citrix.com>

Date: Tue Nov 26 10:45:03 2013

Last Update: Tue Nov 26 10:45:03 2013

Severity: normal

Affects:

State: Open

[ Retrieve as mbox ]


From: Ian Campbell <Ian.Campbell@citrix.com>
To: Wei Liu <wei.liu2@citrix.com>
Cc: xen-devel <xen-devel@lists.xen.org>, NiX <nix@myproxylists.com>, xen-users@lists.xen.org
Subject: Re: [Xen-devel] [Xen-users] XEN 4.3.1 VNC TLS is not working?
Date: Tue, 26 Nov 2013 10:35:42 +0000
Message-ID: <1385462142.23112.11.camel@kazak.uk.xensource.com>

[ Reply to this message; Retrieve Raw Message; Archives: gmane, marc.info ]

create !
title it xl missing support for encrypted VNC
thanks

Creating a bug to remember this. Sadly the original thread predates even
the historical messages which the bug tracker was seeded with. The links
below will have to suffice.

Ian.

On Tue, 2013-11-26 at 10:20 +0000, Ian Campbell wrote:

> > Sadly that might be missing bit in libxl.
> 
> I swear I wrote this code way back, apparently it never went in:
> http://lists.xenproject.org/archives/html/xen-devel/2011-12/msg01353.html
> http://lists.xenproject.org/archives/html/xen-devel/2012-01/msg00240.html
> towards the end I say I'm going to resend, but if I did I can't find
> it... (I searched three months into the future).
> 
> Does any one fancy picking that stuff up and rebasing it?
> 
> Ian.
> 
> 
> _______________________________________________
> Xen-users mailing list
> Xen-users@lists.xen.org
> http://lists.xen.org/xen-users



_______________________________________________
Xen-devel mailing list
Xen-devel@lists.xen.org
http://lists.xen.org/xen-devel


From: Robby <robbyke@gmail.com>
To: Ian.Campbell@citrix.com
Cc: xen-devel@lists.xen.org, xen-users@lists.xen.org, wei.liu2@citrix.com
Subject: Re: [Xen-devel] [Xen-users] XEN 4.3.1 VNC TLS is not working?
Date: Thu, 05 Jun 2014 20:36:50 +0200
Message-ID: <5390B8C2.40903@gmail.com>

[ Reply to this message; Retrieve Raw Message; Archives: gmane, marc.info ]

Hello,

In the meantime more than half a year has gone by (more when considering
the date patches were submitted). Any chance as to getting this
implemented before the end of this year? We'd really like to have VNC
encryption using XL without having to resort to tricks or hacks.

http://bugs.xenproject.org/xen/bug/24

Regards,
Robby

_______________________________________________
Xen-devel mailing list
Xen-devel@lists.xen.org
http://lists.xen.org/xen-devel

From: Wei Liu <wei.liu2@citrix.com>
To: Robby <robbyke@gmail.com>
Cc: wei.liu2@citrix.com, xen-users@lists.xen.org, xen-devel@lists.xen.org, Ian.Campbell@citrix.com
Subject: Re: [Xen-devel] [Xen-users] XEN 4.3.1 VNC TLS is not working?
Date: Thu, 5 Jun 2014 19:53:00 +0100
Message-ID: <20140605185300.GA11959@zion.uk.xensource.com>

[ Reply to this message; Retrieve Raw Message; Archives: gmane, marc.info ]

On Thu, Jun 05, 2014 at 08:36:50PM +0200, Robby wrote:
> Hello,
> 
> In the meantime more than half a year has gone by (more when considering
> the date patches were submitted). Any chance as to getting this
> implemented before the end of this year? We'd really like to have VNC
> encryption using XL without having to resort to tricks or hacks.
> 
> http://bugs.xenproject.org/xen/bug/24
> 

I am currently busy with other stuffs. If you want to pick up that
series, you can have a look at
  http://wiki.xen.org/wiki/Submitting_Xen_Project_Patches

Wei.

> Regards,
> Robby

_______________________________________________
Xen-devel mailing list
Xen-devel@lists.xen.org
http://lists.xen.org/xen-devel